enabling ssh login to AIX server

Enabling SSH Login

Enabling SSH Login to root

Go the /etc/ssh directory where you find sshd_conf ig file
vi sshd_config
there you will find the " PermitRootLogin no " make this to

PermitRootLogin yes


Then root will be able to login



How to find out the problem with your sshd


just type /usr/sbin/sshd -d on your command prompt it will debug your sshd

then you can see the problem

# /usr/sbin/sshd -d
debug1: sshd version OpenSSH_5.0p1
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-d'
debug1: Bind to port 22 on ::.
Bind to port 22 on :: failed: Address already in use.
Cannot bind any address.


How to resolve the problem Bind to port 22 on :: failed: Address already in use.


Go the /etc/ssh directory where you find sshd_conf ig file
vi sshd_config

then you will find the below lines

#Port 22
AddressFamily IPV6
#ListenAddress 0.0.0.0
#ListenAddress ::


then comment all the lines

then the stop and start the sshd

stopsrc -g ssh
startsrc -g ssh

then the problem will be solved you will be able to connect to the server by SSH.


Number of Hits : Hit Counter by Digits

Changing the time Zone in Linux and AIX

Changing the Time Zone in Linux.


  1. Logged in as root, check which timezone your machine is currently using by executing `date`. You'll see something like Mon 17 Jan 2005 12:15:08 PM PST, PST in this case is the current timezone.

  2. Change to the directory /usr/share/zoneinfo here you will find a list of time zone regions. Choose the most appropriate region, if you live in Canada or the US this directory is the "America" directory.

  3. If you wish, backup the previous timezone configuration by copying it to a different location. Such as

    mv /etc/localtime  /etc/localtime-old
  4. Create a symbolic link from the appropiate timezone to /etc/localtime. Example:

    ln -sf /usr/share/zoneinfo/Europe/Amsterdam /etc/localtime
  5. If you have the utility rdate, update the current system time by executing

    /usr/bin/rdate -s time-a.nist.gov
  6. Set the ZONE entry in the file /etc/sysconfig/clock file (e.g. "America/Los_Angeles")

  7. Set the hardware clock by executing:

    /sbin/hwclock --systohc

Tips




  • The time server parameter for rdate can be any public server that supports the RFC-868 time protocol. A list of public RFC-868 servers can be found at [2]. Note: As of April 2007, NIST announced it would phase out support for RFC-868 (scroll to the bottom of [3] to see the announcement). This has not happened as of April 2009).

  • On some versions of RedHat Linux, Slackware, Gentoo, SuSE, Debian, Ubuntu, and anything else that is "normal", the command to display and change the time is 'date', not 'clock'

  • On RedHat Linux there is a utility called "Setup" that allows one to select the timezone from a list, but you must have installed the 'redhat-config-date' package. <>

  • On mobile phones and other small devices that run Linux, the time zone is stored differently. It is written in /etc/TZ, in the format that is described, for instance, in [4]. Edit this file manually or use echo (for instance, echo GMT0BST > /etc/TZ to set the the timezone of the United Kingdom).

  • To setup UTC :

  • vi /etc/sysconfig/clock and change the UTC line to: "UTC=true"

  • On systems that use dpkg (for example Debian and Ubuntu/Kubuntu), you should try "sudo dpkg-reconfigure tzdata". This will set up everything correctly in very few, simple steps.





Warnings



Some applications (such as PHP) have separate timezone settings from the system timezone.

  • On some systems, there is a system utility provided that will prompt for the correct timezone and make the proper changes to the system configuration. For example, Debian provides the "tzsetup" or "tzconfig" utility.



Changing the Time


To change the time use date followed by the month, day, hour, minute, and year all numeric and no spaces. So, to set the date and time to November 2nd, 2003 12:57



Changing the Time zone in AIX

TO change the Time zone in AIX

1) smitty
2) selce the system environment
3) select the change time
4) select the change the time zone using user defined
6) enter the the time zone and valu Like IST , _5:30

Than you are done with the time zone.
But AIX needs the Reboot .
Number of Hits : Hit Counter by Digits

Using Crontab in UNIX

1. Controls on Using the crontab Command

The /var/adm/cron/cron.allow and /var/adm/cron/cron.deny files control which users can use the crontab command A root user can create, edit, or delete these files.


Entries in these files are user login names with one name to a line. If your login ID is associated with more than one login name, the crontab command uses the first

login name that is in the /etc/passwd file, regardless of which login name you might actually be using. Also, to allow users to start cron jobs, the daemon attribute in

the /etc/security/user file should be set to TRUE , using the chuser command.


The following is an example of an cron.allow file:


root

nick

dee

sarah


If the cron.allow file exists, only users whose login names appear in it can use the crontab command. The root user's log name must appear in the cron.allow file if the

file exists. A system administrator can explicitly stop a user from using the crontab command by listing the user's login name in the cron.deny file. If only the

cron.deny file exists, any user whose name does not appear in the file can use the crontab command.


A user cannot use the crontab command if one of the following is true:

* The cron.allow file and the cron.deny file do not exist (allows root user only).

* The cron.allow file exists but the user's login name is not listed in it.

* The cron.deny file exists and the user's login name is listed in it.


If neither the cron.allow nor the cron.deny file exists, only someone with root user authority can submit a job with the crontab command.




2. Crontab Commands

export EDITOR=vi ;to specify a editor to open crontab file.


c -e UserName

Edits a copy of the user's crontab file or creates an empty file to edit if the crontab file does not exist for a valid UserName. When editing is complete, the

file is copied into the crontab directory as the user's crontab file.

-l UserName

Lists the user's crontab file.

-r UserName

Removes the user's crontab file from the crontab directory.

-v UserName

Lists the status of the user's cron jobs.


3. Crontab file


Crontab syntax :-

A crontab file has five fields for specifying day , date and time followed by the command to be run at that interval.

* * * * * command to be executed

- - - - -

| | | | |

| | | | +----- day of week (0 - 6) (Sunday=0)

| | | +------- month (1 - 12)

| | +--------- day of month (1 - 31)

| +----------- hour (0 - 23)

+------------- min (0 - 59)



* in the value field above means all legal values as in braces for that column.

The value column can have a * or a list of elements separated by commas. An element is either a number in the ranges shown above or two numbers in the range separated by a hyphen (meaning an inclusive range).


Note: The specification of days can be made in two fields: month day and weekday. If both are specified in an entry, they are cumulative meaning both of the entries will get executed .


4. Crontab Example



2 To write the time to the console every hour on the hour, enter:


0 * * * * echo The hour is `date` .

>/dev/console

3 To run the calendar command at 6:30 a.m. every Monday, Wednesday, and Friday, enter:


30 6 * * 1,3,5 /usr/bin/calendar


4 To run the calendar command every day of the year at 6:30, enter the following:


30 6 * * * /usr/bin/calendar

5 To run a script called maintenance every day at midnight in August, enter the following:


0 0 * 8 * /u/harry/bin/maintenance

6 To define text for the standard input to a command, enter:


0 16 * 12 5 /usr/sbin/wall%HAPPY HOLIDAY!%Remember to

turn in your time card.

The text following the % (percent sign) defines the standard input to the wall command as:


HAPPY HOLIDAY!


Remember to turn in your time card.


5. Crontab Environment

cron invokes the command from the user's HOME directory with the shell, (/usr/bin/sh).

cron supplies a default environment for every shell, defining:

HOME=user's-home-directory

LOGNAME=user's-login-id

PATH=/usr/bin:/usr/sbin:.

SHELL=/usr/bin/sh


Users who desire to have their .profile executed must explicitly do so in the crontab entry or in a script called by the entry.


6. Disable Email


By default cron jobs sends a email to the user account executing the cronjob. If this is not needed put the following command At the end of the cron job line .


>/dev/null 2>&1


7. Generate log file


collect the cron execution execution log in a file :
30 18 * * * rm /home/someuser/tmp/* > /home/someuser/cronlogs/clean_tmp_dir.log

Number of Hits : Hit Counter by Digits

Not able to FTP as root in AIX

Not able to FTP as Root



This is the problem many number of the system admins face.

1) First check the /etc/ftpusers file

if that file exist then edit that file and remove the root entry there in that file

2) check for the ports that are active for the FTP or not.

3)If you are using ip adresses, make sure the servers can ping each other by ip adress. If you are using hostnames, then make sure the two servers can resolve each other's hostname.

4) Check the /etc/inetd.conf file

where the /usr/sbin/ftpd ftpd must not be commented.
if comented please remove the comment ( #)


5) check for the /etc/services

in this file check for the FTP services they must not be commented.
Check for the FTP/TCP and FTP/UDP and all services related to FTP.
they must not be comented.

6) Finally and most importent thing is

The shell of the root also important , if the root's default shell is 'bash' then you will not be able to FTP to that server by root.
Please chanag the root default shell to ksh.

Number of Hits : Hit Counter by Digits

AIX boot Process

AIX Boot process .





1)you power on the AIX server
2)The POST ( Power On Self Test ) will be done .

It varifies the basic hardware, Check is it is in functional state or not.
The memory,keyboard, communication and audio devices are also initialized
we can see the icons on the the screen
3)This is the correct step where you can select the boot list by pressing function key
4)The LED values displayed during this phase are model specific.
5)The system read only Storage is specific to the system type. It is the one which is used to boot the system ,but it will not contain any data structure.
This ROS contain only the location to the bootstrap .
It will load the the Bootstrap .
ROS contains generic boot information and is operating system independent.
6)The bootstrap also called as software ROS.
This bootstrap contains IPL ( Initial Program loader )
Which is used to build AIX specific boot information.
Software RS is AIX 5L information created based on machine type and is responsible for completing machine preparation to enable it to start AIX 5L kernel.
7)A special file system will be created in memory called RAMFS ,
8)Bootstrap locates and loads the BLV in to memory and gives control to BLV
9)BLV ( boot Logical volume )
The complete list of files that are there in BLV can be found in /usr/lib/boot.
The AIX 5L kernel
The boot command called during the booting process like cfgmgr, bootinfo
The reduced version of ODM ( object Data Manager ),
The hd4 contains all the device spcific methods info , but before loading we need
some devices like keyboard more . So the BLV contains methods to load those
devices .
The rc.boot program

10)Then BLV loads complete AIX kernel,and gives control. LED 0299.
11)All Previous LED values are hardware specific.
12)Complete the boot process by lading all the devices.
13) LED codes displayed during this stage will be generic AIX 5L specific
14)Now Init process will be started
15)Till now the rootvg is not mounted.
16)Till now the rc.boot script called 3 tiles with 1, 2, 3 arguments.
We call this as the 3 phases of initialization .
17)rc.boot 1 -----> Boot phase 1.
a) The init process started from RAMFS executes the boot script rc.boot 1
b) If init process fails the LED code will be c06.
c) restbase will be called in this phase to copy the partial copy of the ODM from BLV to RMFS.
d) IF successful then shows 510 , if fails 548 on LED.
e) After this, the cfgmgr -f command reads the Config_Rules class from the reduced ODM

f) devices with the attribute phase=1 are considered base devices. Base devices are all
devices that are necessary to access rootvg.
g) Like all the devices that are there to acced rootvg from mothere board to Hard disk
will be activated.
h) The bootinfo -b will be called to determine the last boot device .

18)rc.boot 2 -----------> Boot Phase 2.

a) The rootvg volume group is varied on with the special version of the varyonvg
ipl_varyon command
b) If this command is successful the LED value will be 517.
c) If failed LED value will be 552, 554, 556 and the boot process is halted.
d) Root file system hd4 is checked using the fsck -f command. This will verify
whether the lass shutdown was clean .
e) if command fails system will show 555
f) The root file system (/dev/hd4) is mounted on a temporary mount point /mnt in
RMFS
g) If this fails, 557 will appear in the LED display.
h)The /usr file system is verified using the fsck -f command and then mounted.
i) If fails then LED value will be 518.
j) The /var file system is verified using the fsck -f command and then mounted.
k) Then copycore command will check for dumps if exist then copy form the
default dump device /dev/hd6 to default directory /var/adm/ras.
l) After this /var is unmounted
m) The primary paging space from rootvg, /dev/hd6, will be activated.
n) The mergedev process is called and all /dev files from the RAM file system
copied on to disk.
o) All customized ODM files from the RAM file system are copied to disk.
p) Both ODM versions from hd4 and hd5 are now synchronized.
q) Finally, the root file system from rootvg (disk) is mounted over the root
filesystem from the RMFS.
r) The mount points for the rootvg file system is available now.
s) then /var /usr are mounted again on normal mount points.
t) There is no console available at this stage.so all the messages are copied to alog.
u) alog is program that maintain all the logs.

19) rc.boot 3 -----------> Boot Phase 3.

a) /etc/init program starts and reades the /etc/inittab callas rc.boot with 3.
b) The /tmp file system is mounted.
c) The rootvg is synchronized by calling the syncvg command and launching it as
as a background process.
d) As a result all stale partitions from rootvg are the LEC value is 553.
e) At this stage, the cfgmgr command is called: if the system is booted in normal
mode with the option -p2.
if it booted in service mode the cfgmgr is called with -p3 option.
f) The cfgmgr command reads the Config_rules file from oDM and calls all
methods corresponding to either phase=2 or phase=3.
g) All the devices that are not basic devices are initialized.
h) The console is configured by calling the cfgcon command , Now boot
messages are sent to console .
i) if there is any problem in console the messages are stored in
/var/adm/ras/conslog.

20)Finally the syncronization of ODM done from BLV with /root filesystem is done. Savebase command.
21)he syncd daemon and errdemon are started.
22)LED display went off.
23)If the file /etc/nologin exists, it will be removed.
24)If there are devices marked as missing in CuDv a message is displayed on the console
25)The message System initialization completed is sent to the console.
The execution of rc.boot is has completed the process init will continue the next command from /etc/inittab .








Number of Hits :
Hit Counter by Digits

Boot Problem in AIX corrupted BLV

Booting Problem in AIX


Here is the Procedure to Fix a Corrupted BLV (boot logical volume).





AIX Server stop booting if the your BLV is corrupted .By showing the LED value 557.


To fix this Problem , you must boot your machine in maintenance mode, from a CD or tape. If NIM has been set up for a machine, you can also boot the machine from a NIM master in maintenance mode.

We can set the boot list by “ bootlist” Command , or by SMS program.

Some machines support a normal and service boot list. If your model supports this, you will use a function key during bootup to select the appropriate list.
Normally, pressing F5 when you hear the first tones during bootup, will force the machine to check for a bootable CD.

Press the F5 continually ..................







After booting from CD, tape or NIM an Installation and Maintenance Menu is shown and you can startup the maintenance mode.

Access the rootvg,

Then you can repair the boot logical volume with the bosboot command.
Please specify the disk device, for example hdisk0:

Command : -- # bosboot -ad /dev/hdisk0

It is important that you do a proper shutdown. All changes need to be written from memory to disk.

The bosboot command requires that the boot logical volume hd5 exists.

If the BLV not existing ( deleted mistakenly ) you can create it from the scratch.
Please follow the below steps.

1. Boot your machine in maintenance mode (from CD or tape).
2. Create a new hd5 logical volume: one physical partition in size, must be in rootvg. Specify boot as logical volume type.
3. Run the bosboot command as described.
4. Reboot the server run command

# shutdown -Fr


Procedure of re-creating boot logical volume (BLV)

1. Boot your machine in maintenance mode (from CD, tape, or NIM).

2. Create a new hd5 logical volume: one physical partition in size, must be in rootvg. Specify boot as logical volume type. if needed, remove hd5 using # rmlv -f hd5

# mklv -y hd5 -t boot -a e rootvg 1

3. Run the bosboot command as described below.

# bosboot -ad /dev/hdisk0

4. Shutdown -Fr.









Hit Counter by Digits

Device management in AIX

TO lists all installed devices in AIX
lscfg
lscfg -v
lscfg -vl

TO Know last device the system booted from
bootinfo -b
bootinfo -k ----> keyswitch position
1=secure, 2=service, 3=normal

To know the amount of memory in 1024

bootinfo -r
bootinfo -s command to know the size of disk drive
bootinfo -T type of machine ie rspc

lsattr -El sys0 -a realmem ---- > comad to know the usable memory.

mknod c Creates a /dev/ device file.
mknod /dev/null1 c 2 3

To displays customized devices ie installed
lsdev -C displays customized devices ie installed

To pre-defined devices ie supported

lsdev -P
lsdev -(C or P) -c (class) -t (type) -s (subtype)

How to Change a device attribute
chdev -l (device) -a (attribute)=(new value)
chdev -l sys0 -a maxuproc=80

lsattr -EH -l (device) -D Lists the defaults in the pre-defined db
lsattr -EH -l sys0 -a modelname

TO change the device state from defined state to available state.
rmdev -l (device)
rmdev -l (device) -d Delete the device
rmdev -l (device) -SR S stops device, R unconfigures child devices


TO Displays bus resource attributes of a device.
lsresource -l (device)






Hit Counter by Digits

Restoring the files from the MKSYSB image backup

How do I restore specific files from a mksysb tape


To recover specific files from a backup made with mksysb
$ tctl -f /dev/rmt1 rewind
$ tar xvf /dev/rmt0.1 ./your/file/name

$ tctl -f /dev/rmt1 rewind
$ restore -xvf /dev/rmt0.1 ./your/file/name

Restore the file: restore -x -d -q -s4 -f /dev/rmt0.1
-s4 indicated that we are restoring 4th image on the tape,

Use rmt0.1, means no rewind on close and no retension on open.

If the backup was taken with -i flag, you can use the following command:
restore -x -d -v -q -f /dev/rmt0

If the mksysb backup was taken with file system backup, you can use the following command:
restore -x -v -q -f /dev/rmt0

Restoring A Directory File From mksysb Image
If you want to restore a full directory from the mksysb archive on /dev/rmt0. Here you have to specify the directory name instead of a single file:
Rewind The tape: tctl -f /dev/rmt1 rewind

Restore the file: restore -x -d -s4 -f /dev/rmt0.1

if the backup was taken with -i option then it will be:
restore -x -d -v -q -f /dev/rmt0

If the backup was taken with filesystem backup option then it will be:
restore -x -v -q -f /dev/rmt0




Number of Hits :

Creating Image of AIX by using MKSYSB





We can create the image of the running AIX OS in to tape or in to a file by using MKSYSB command in AIX or in other words Creating an installable image of the root volume group either in a file or onto a bootable tape.

It is use full when the server crashes or when the server is down with some ODM problem or if system admin executed rm –R on root .

For the production servers it is recommended that every 1 month image of the running OS should be maintain in a secure place.

Helps in Provisioning the AIX OS

We can create a good image of running AIX OS with all the requisites for our environment and it will help us in provisioning the same image to all the P series machines in a same project so that all the machines will be of same configuration and at same level because mksysb creates backup of the running OS .


Creating a image on Tape

By the following command we can create the image on tape .


1) mksysb –i /dev/rmt0
It create the backup of the running OS on the tape , which will be bootable .

2) mksysb –m /dev/rmt0
Create the image with map files

3) mksysb –i
Create the backup on a file


Excluding the file in the backup

We can exclude the files that which we don’t want to backup , many reasons we don’t want to backup some files , the size of the file is one the major thing.

We need to follow below procedure to exclude the file from backup

1) Create the file name with /etc/exclude.rootvg
2) Write the file name that you want to exclude in the exclude.rootvg
3) Execute the command mksysb –ei /dev/rmt0





Notes:
1. The image the mksysb command creates does not include data on raw devices or in user-defined paging spaces.
2. If you are using a system with a remote-mounted /usr file system, you cannot reinstall your system from a backup image.
3. The mksysb command may not restore all device configurations for special features, such as /dev/netbios and some device drivers not shipped with the product.
4. Some rspc systems for AIX 5.1 and earlier do not support booting from tape. When you make a bootable mksysb image on an rspc system for AIX 5.1 and earlier that does not support booting from tape, the mksysb command issues a warning indicating that the tape will not be bootable. You can install a mksysb image from a system that does not support booting from tape by booting from a CD and entering maintenance mode. In maintenance mode you will be able to install the system backup from tape.
5. The mksysb command uses the backup command to create its archive image. The mksysb command will also save the EA format for any JFS2 filesystems being backed up. It uses the /usr/bin/mkvgdata shell script to save this information.







number of Hits :


Hit Counter by Digits

How to create the user same privileges as root in UNIX

Tech INFO

You can create a user with the same privileges as root

Steps:






1) create the user

smitty user ->add user
2)edit the etc/filesystem

modified your user row same as root user row.

this will allow the user with all the operations a root can do.

But It is not good paractice . please give the user with sudo access.


Note: If you want to change the password of the new user ID. first change the UID to some thing else than 0, and then change the password and again change the UID to 0.

If not you will be prompted to change the root password to change it when you login as root.







Number of hits :

IBM Director Installation Prerequisites





IBM Director Installation Prerequisites.


Hardware requirements for running IBM Systems Director Server


IBM® Systems Director Server has certain hardware requirements. These requirements can vary depending on the size of your IBM Systems Director systems-management environment.

Recommended hardware requirements for IBM Systems Director Server running on Linux on x86-compatible systems

IBM® Systems Director Server has certain hardware requirements to run on x86-compatible systems running Linux®. These requirements can vary depending on the size of your IBM Systems Director systems-management environment.
The following recommendations are for three types of IBM Systems Director systems-management environments:

Small configuration

A systems-management environment that includes less than 500 Common-Agent managed systems. The database software is Apache Derby.

Medium configuration


A systems-management environment that includes between 500 and 1000 Common-Agent managed systems. The database software is IBM DB2®.


Large configuration


A systems-management environment that includes between 1000 and 5000 Common-Agent managed systems. The database software is IBM DB2.
When reviewing these recommendations, consider the following information:
• Installation and startup times improve with faster disk access times. SCSI adapters and 10 K RPM drives provide the best performance.
• Disk sizes are arbitrary and indicative of disk requirements.
• System performance depends on the nature of your requirements and system workload.
• The IBM DB2 database software sizing should be comparable for Oracle and Microsoft® SQL Server. The sizing presumes that DB2 is running on the same server as IBM Systems Director Server.
The following recommendations are based on a 32–bit version of SUSE Linux Enterprise Server 10 for x86. The recommendations are comparable for Red Hat Enterprise Linux on x86-compatible systems.
Table 1. IBM Systems Director Server recommended hardware requirements for different-sized Linux environments
Configuration Recommended hardware requirements
Processor Memory Disk storage
Small 1 processor, 3 GHz Intel® Xeon® 1 1 GB 4 GB
Medium 2 processors, 3 GHz Intel Xeon 1 2 GB 6 GB
Large 4 processors, 3 GHz Intel Xeon 1 4 GB 8 GB
1 The processor (CPU) sizing is based on the Intel Xeon processor, but is comparable for equivalent Intel® and AMD processors.
Attention: If you use DVD media to install IBM Systems Director Server, ensure that you allot an additional 1.2 GB of available space on the system to contain the agent packages that are copied from the DVD at the end of the server installation. The packages are copied to /opt/ibm/director/packaging/agent on the server.








Recommended hardware requirements for IBM Systems Director Server running on AIX

IBM® Systems Director Server has certain hardware requirements to run on IBM Power systems running AIX®, including JS21 and JS22 blade servers. These requirements can vary depending on the size of your IBM Systems Director systems-management environment.
The following recommendations are for three types of IBM Systems Director systems-management environments:
Small configuration
A systems-management environment that includes less than 500 Common-Agent managed systems. The database software is Apache Derby.
Medium configuration
A systems-management environment that includes between 500 and 1000 Common-Agent managed systems. The database software is IBM DB2®.
Large configuration
A systems-management environment that includes between 1000 and 5000 Common-Agent managed systems. The database software is IBM DB2.
When reviewing these recommendations, consider the following information:
• Installation and startup times improve with faster disk access times. SCSI adapters and 10 K RPM drives provide the best performance.
• Disk sizes are arbitrary and indicative of disk requirements.
• System performance depends on the nature of your requirements and system workload.
• The IBM DB2 database software sizing should be comparable for Oracle and Microsoft® SQL Server. The sizing presumes that DB2 is running on the same server as IBM Systems Director Server.
The following recommendations are based on a 32–bit Java™ Virtual Machine (JVM) running on a 64–bit version of AIX.

Note: Common Agent is always installed with IBM Systems Director Server, so ensure that you factor in the Common Agent requirements whenever considering IBM Systems Director Server requirements.

Table 1. IBM Systems Director Server recommended hardware requirements for different-sized AIX environments
Configuration Recommended hardware requirements
Processor Memory Disk storage2
Small 1 processor, POWER5™ or POWER6™1 2.5 - 3 GB 4 GB
Medium 2 processors,POWER5 or POWER61 4 GB 6 GB
Large 4 processors, POWER5 or POWER61 10 GB 8 GB
• 1 The processor (CPU) sizing is based on the IBM® POWER5 processor, but is comparable for equivalent IBM® POWER6 processors.
• 2 Disk storage requirements are for running IBM Systems Director Server.
Paging space should equal or exceed the physical memory size. Ensuring this is particularly critical if the physical memory is close to the 2.5 GB minimum requirement.
The following table provides information about disk storage requirements for installing IBM Systems Director Server. These requirements include Common Agent and Platform Agent, which are installed with IBM Systems Director Server.



Table 2. Disk storage requirements for installing IBM Systems Director Server
File system Disk space required
/ 10 MB
/usr 110 MB
/var 170 MB
/tmp 12 MB
Note: During the installation, /tmp must have 1 GB in free space. This space is only required during the installation and is freed after the installation is complete.
/opt 3 GB
Attention: If you use DVD media to install IBM Systems Director Server, ensure that you allot an additional 1.2 GB of available space in the /opt file system to contain the agent packages that are copied from the DVD at the end of the server installation. The packages are copied to /opt/ibm/director/packaging/agent on the server.





Recommended hardware requirements for IBM Systems Director Server running on Linux on Power Systems
IBM® Systems Director Server has certain hardware requirements to run on IBM Power systems running Linux®, including JS21 blade servers. These requirements can vary depending on the size of your IBM Systems Director systems-management environment.
The following recommendations are for three types of IBM Systems Director systems-management environments:
Small configuration
A systems-management environment that includes less than 500 Common-Agent managed systems. The database software is Apache Derby.
Medium configuration
A systems-management environment that includes between 500 and 1000 Common-Agent managed systems. The database software is IBM DB2®.
Large configuration
A systems-management environment that includes between 1000 and 5000 Common-Agent managed systems. The database software is IBM DB2.
When reviewing these recommendations, consider the following information:
• Installation and startup times improve with faster disk access times. SCSI adapters and 10 K RPM drives provide the best performance.
• Disk sizes are arbitrary and indicative of disk requirements.
• System performance depends on the nature of your requirements and system workload.
• The IBM DB2 database software sizing should be comparable for Oracle and Microsoft® SQL Server. The sizing presumes that DB2 is running on the same server as IBM Systems Director Server.
The following recommendations are based on a 32–bit Java™ Virtual Machine (JVM) running on a 64–bit version of SUSE Linux Enterprise Server 10 on IBM Power Systems™. The recommendations are comparable for Red Hat Enterprise Linux on IBM Power systems.


Table 1. IBM Systems Director Server recommended hardware requirements for different-sized Linux on Power Systems environments
Configuration Recommended hardware requirements
Processor Memory Disk storage 2
Small 1 processor, POWER5™ or POWER6™1 2.5 GB 4 GB
Medium 2 processors,POWER5 or POWER61 4 GB 6 GB
Large 4 processors, POWER5 or POWER61 10 GB 8 GB
• 1 The processor (CPU) sizing is based on the IBM® POWER5 processor, but is comparable for equivalent IBM® POWER6 processors.
• 2 Disk storage requirements are for running IBM Systems Director Server. For installing IBM Systems Director Server, 2.1 GB disk space is required. This requirement includes Common Agent and Platform Agent which are installed with IBM Systems Director Server. Also, during the installation, /tmp must have 1.7 GB in free space. This space is only required during the installation and is freed after the installation is complete.
Attention: If you use DVD media to install IBM Systems Director Server, ensure that you allot an additional 1.2 GB of available space on the system to contain the agent packages that are copied from the DVD at the end of the server installation. The packages are copied to /opt/ibm/director/packaging/agent on the server.


Recommended hardware requirements for IBM Systems Director Server running on IBM® System z servers


IBM® Systems Director Server has certain hardware requirements to run on IBM® System z systems running Linux®. These requirements can vary depending on the size of your IBM Systems Director systems-management environment.
The following recommendations are for three types of IBM Systems Director systems-management environments:



Small configuration
A systems-management environment that includes less than 500 Common-Agent managed systems. The database software is Apache Derby.
Medium configuration
A systems-management environment that includes between 500 and 1000 Common-Agent managed systems. The database software is IBM DB2® Universal Database™.
Large configuration
A systems-management environment that includes between 1000 and 2500 Common-Agent managed systems.
Note: The maximum number of managed systems supported by IBM® System z systems running Linux is smaller than the maximum supported by Linux on other platforms because of the limitation imposed by the 31-bit Java Virtual Machine (JVM).
The database software is IBM DB2 Universal Database.
When reviewing these recommendations, consider the following information:
• Disk sizes are arbitrary and indicative of disk requirements.
• System performance depends on the nature of your requirements and system workload.
• The IBM DB2 Universal Database software sizing should be comparable for Oracle® Database and Microsoft® SQL Server. The sizing presumes that IBM DB2 Universal Database is running on the same server as IBM Systems Director Server.
The following recommendations are based on a 31–bit JVM running on a 64–bit version of SUSE Linux Enterprise Server 10 on IBM® System z systems. The recommendations are comparable for Red Hat Enterprise Linux on IBM® System z systems.





Table 1. IBM Systems Director Server recommended hardware requirements for different Linux configuration sizes on System z systems environments
Configuration Recommended hardware requirements
Processor Memory Disk storage2
Small 1 processor, IBM® System z9 or above1 2 GB 3.5 GB (in /opt)
1.0 GB (in /tmp)
Medium 2 processors, IBM® System z9 or above1 4 GB 4.5 GB (in /opt)
1.0 GB (in /tmp)
Large 4 processors, IBM® System z9 or above1 8 GB 6.5 GB (in /opt)
1.0 GB (in /tmp)
1. The processor sizing is based on the IBM® System z9 EC processor, but is comparable for equivalent System z processors. The processor usage by IBM Systems Director Server is high during certain tasks. It is recommended that, if processors are shared, the partition that is used to run IBM Systems Director Server be given a lower partition weight than production partitions.
2. Disk storage requirements are for running IBM Systems Director Server. For installing IBM Systems Director Server, space is required in /opt. This requirement includes Common Agent and Platform Agent, which are installed with IBM Systems Director Server. Also, during the installation, /tmp must have free space as specified. This space is only required during the installation and is freed after the installation is complete.
Attention: If you use DVD media to install IBM Systems Director Server, ensure that you allot an additional 1.2 GB of available space on the system to contain the agent packages that are copied from the DVD at the end of the server installation. The packages are copied to /opt/ibm/director/packaging/agent on the server.











Hardware requirements for systems running Common Agent or Platform Agent (client )


Common Agent and Platform Agent have minimum processor speed, random access memory (RAM), and disk space requirements.
Note: The disk space listed is the minimum requirement for an installation using the default selections.
x86-compatible systems
Notes:
• The systems on which you install Common Agent must meet the Wired for Management (WfM), version 2.0, specifications.
• System Management BIOS (SMBIOS) 2.1 or later is required for all systems in an IBM® Systems Director environment.
Table 1. x86-compatible systems: Minimum hardware requirements
Requirements Platform Agent Common Agent
Processor speed Pentium 1.5 Ghz or equivalent Pentium 1.5 Ghz or equivalent
Memory (RAM) 512 MB 512 MB
Disk space 40 MB (for Windows®)
100 MB (for Linux®) 110 MB (for Windows)
170 MB (for Linux)
IBM Power systems running IBM i
Table 2. IBM Power systems running IBM i: Minimum hardware requirements
Requirements Common Agent
Relative system performance 150 commercial processing workload (CPW)
Storage pool size 350 MB
Disk space 300 MB




IBM Power systems running AIX®


Note: On systems that do not provide display capability, such as JS21 and JS22 blade servers, you must export IBM Systems Director Web interface using either the xhost command or SSH tunneling. The IBM Systems Director Web interface requirements apply to the receiving system.
Table 3. Servers running AIX: Minimum hardware requirements
Requirements Common Agent
Processor speed POWER5™ or POWER6™
Memory (RAM) 512 MB (minimum)
The following table provides information about disk storage requirements for installing Common Agent.


Table 4. Disk storage requirements for installing Common Agent
File system Disk space required
/ 10 MB
/usr 110 MB
/var 170 MB
/tmp 12 MB
/opt 190 MB
Note: During the installation, /tmp must have 280 MB in free space. This space is only required during the installation and is freed after the installation is complete.
If you are installing the Common Agent using the Agent Installation Wizard, the following disk space is required, in addition to the required installation disk space stated above:
• 210 MB for the dir6.1.0.0_commonagent_aix.sh file
• 210 MB for the extracted installation file sets
IBM Power systems running Linux
Note:




On systems that do not provide display capability, such as JS21, QS21, and QS22 blade servers, you must export the IBM Systems Director Web interface using either the xhost command or SSH. The IBM Systems Director Web interface requirements apply to the receiving system.
Table 5. Servers running Linux on Power Systems™: Minimum hardware requirements
Requirements Platform Agent Common Agent
Processor speed POWER5 or POWER6 POWER5 or POWER6
Memory (RAM) 128 MB (minimum) 512 MB (minimum)
Disk space for installing the agent 145 MB
210 MB for the temporary space 370 MB 1
490 MB for the temporary space
Additional disk space required when installing the agent using the Agent Installation Wizard 120 MB 420 MB
1 This requirement includes Platform Agent which is installed with Common Agent.
System z servers
Table 6. System z servers: Minimum hardware requirements
Requirement Platform Agent Common Agent Common Agent with CIM instrumentation for z/VM® manageability access point
Processor speed Processor speeds provided by IBM® System z and zSeries® servers are sufficient for IBM Systems Director agents. These models are:
• IBM® System z (System z10™ Enterprise Class, System z9® Enterprise Class, and System z9 Business Class)
• IBM® zSeries (IBM® zSeries 990, 900, 890 and 800)
Memory 512 MB 512 MB 512 MB
Disk space 200 MB 500 MB 200 MB






PORTS:

Important port considerations


When preparing your ports for an IBM® Systems Director environment, there are some important considerations to remember or some IBM Systems Director functions might not work.
Review the following considerations:
• Depending on the system configuration, one of the following port pairings must be open in order to install IBM Systems Director:
• (For Microsoft® Windows® and Red Hat Enterprise Linux®) 5988 and 5989
• (For SUSE Linux Enterprise Server) 15988 and 15989
Some firewalls might attempt to block these ports. Make sure that the IBM Systems Director software components can use these ports. If custom alternative ports are chosen for the CIM Server, then those ports must be opened.
• (Windows only) For any CIM-related function of the Common Agent to work, the HTTP port must be turned on for the Pegasus CIMOM, regardless of whether HTTPS is turned on (SSL is enabled).
• If the CIMOM ports for a Platform-Agent managed system are changed after IBM Systems Director Server discovers the system, the system will change to an Agentless-managed system in IBM Systems Director. To correct this change, you must complete the following steps:
1. Delete the system in IBM Systems Director.
2. Shut down and restart the system.
3. Discover the system in IBM Systems Director.
• Windows firewall can interfere with discovery of managed systems running Windows 2003, Windows 2008, Windows XP, and Windows Vista.
• If a proxy server is required to access the Internet from the management server, make sure that the management server is configured to use the proxy.
• Update manager cannot use Digest or NTLM authentication to access update packages from IBM®. If a proxy server is required, it must be configured to use Basic authentication.
• IBM Systems Director Server can access the Internet through ports 80 (HTTP) and 443 (HTTPS). The firewall and proxy server must permit bi-directional communication through these ports.
• By default, IBM Systems Director uses a random source port for SLP communication through a firewall to a Remote Supervisor Adapter. The random port causes problems when discovering the Remote Supervisor Adapter through a firewall because the Remote Supervisor Adapter responds using that random port. To resolve this problem, open any unused or private port. Then, edit the slp.prop file to use your selected port. The following example uses port 49150:
• # Up to 10 parallel ports can be open at a time
• # when opening firewall ports, configure the source port and open
• # that port and the next 9 consecutive ports
• # default: 0 - random port used
source.port=49150
• Neither z/VM® nor the MAP Agent add any additional ports to those already provided by IBM Systems Director for standard communication. Instead of TCP/IP, z/VM communication APIs are used to communicate with the servers that provide information to IBM Systems Director and to enact any changes to z/VM servers. The communication is by means of sockets and the AF_IUCV address family.
• For the TCP ports listed, the initiator opens a random port in the 1024-65535 range and then connects to the listener on the port listed. The listener responds by connecting to the original random port opened by the initiator.
• For the getfru command to run successfully, the managed system must have firewall access through a standard FTP port.
• The Remote Control, Update Install, and the Agent Installation wizard tasks use session support to increase data transmission. Session support within TCP/IP causes data to flow through a nonreserved port that is different from the one that IBM Systems Director typically uses for communication. Most firewalls will not transmit the data through this other port.


Ports for IBM Systems Director Server


IBM® Systems Director processes require access to a number of ports on the management server. If these ports are blocked by a firewall or used by another process, some IBM Systems Director functions might not work.
Table 1. Ports used by IBM Systems Director Server for communication
Port TCP or UDP Direction Communication description
20 TCP Inbound FTP data communication with BladeCenter® I/O modules (switches and bridges)
21 TCP Inbound FTP communication with BladeCenter I/O modules (switches and bridges)
22 TCP Outbound SSH communication with:
• Advanced management module and management module
• BladeCenter I/O modules
• Platform Agent installed on systems running Linux®, including systems managed by HMC and IVM
• SSH used by IBM Power systems to communicate with HMC/IVM
• Non-Windows Agentless-managed systems
23 TCP, UDP Outbound Telnet communication with:
• Advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II
• BladeCenter I/O modules
• Updates
69 TCP Inbound TFTP communication with BladeCenter I/O modules (switches and bridges)
80 TCP Outbound HTTP communication with:
• IBM Systems Director Web interface
• Advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II
• BladeCenter I/O modules
• IVM interface
• Update manager
81 TCP Outbound HTTPS communication with BladeCenter I/O modules (switches and bridges)
135 TCP, UDP Outbound (Windows® only) Software installation and remote access communication with Platform Agent
137 TCP, UDP Outbound (Windows only) Communication with Agentless-managed systems using Microsoft® Windows DCOM
138 TCP, UDP Outbound (Windows only) Communication with Agentless-managed systems using Windows DCOM
139 TCP, UDP Outbound (Windows only) Communication with Agentless-managed systems using Windows Server Message Block (SMB)
161 UDP Outbound SNMP agent communication with:
• Advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II
• BladeCenter I/O modules
• Platform Agent
Note: This port is used when the SNMP agent for the operating system is configured.
• Agentless-managed systems
Note: This port is used when the SNMP agent for the operating system is configured.
162 TCP, UDP Outbound (TCP, UDP)
Inbound (UDP) Simple Network Management Protocol (SNMP) trap communication with SNMP devices, including TCP for Tivoli® NetView® events. Examples of SNMP devices are advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II.
427 TCP, UDP Outbound and Inbound SLP communication with:
• Advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II
• Common Agent
• Platform Agent
• IBM Director Agent 5.20
• Service Location Protocol (SLP) service agent or SLP directory agent
443 TCP Outbound HTTPS communication with:
• IBM Systems Director Web interface
• Advanced management module and management module
• HMC Web interface
• Updates
445 TCP, UDP Outbound (Windows only) Open on Agentless and Platform-Agent managed systems for the following features:
• Software installation
• Remote access communication
• (Agentless-managed systems only) Inventory collection
446 TCP Outbound Non-SSL communication with the IBM i DRDA/DDM server job
448 TCP Outbound SSL communication with the IBM i DRDA/DDM server job
449 TCP Outbound SSL communication with the IBM i server port mapper
623 UDP Outbound Remote Management and Control Protocol (RMCP) unsecure communication with IPMI baseboard management controller (BMC) service processors
664 UDP Outbound Remote Management and Control Protocol (RMCP) secure communication with IPMI BMC service processors
Random port in the 1024-65535 range TCP Inbound • Random port range for communication between IBM Systems Director Server with Intelligent Platform Management Interface (IPMI) service processors
Note: You can specify a fixed port by modifying the asmDefinitions.properties file in the data directory.
• For the TCP ports listed, the initiator opens a random port in the 1024-65535 range and then connects to the listener on the port listed. The listener responds by connecting to the original random port opened by the initiator.
1433 TCP Outbound and Inbound Microsoft SQL Server databases
1521 TCP Outbound and Inbound Oracle® Database databases
1527 TCP Outbound and Inbound Apache Derby databases
2033 TCP Inbound Communication with the IBM Systems Director Launched Tasks program using IBM Systems Director interprocess communication (IPC)
2044 TCP Outbound and Inbound smcli command-line interface
Note: This port number can be changed. See "Port configuration for smcli."
3389 TCP Outbound and Inbound Remote Desktop Protocol, Remote Desktop Connection, or Remote Accessor for full screen access to systems running Windows
4066 TCP Inbound Communication with the IBM Systems Director Launched Tasks program using IBM Systems Director interprocess communication (IPC) over SSL
5901 TCP Outbound and Inbound Virtual Network Computing (VNC), used by Remote Access
5988 TCP Inbound (Windows and Red Hat Enterprise Linux) CIM Server unsecure port
5989 TCP Inbound • (Windows and Red Hat Enterprise Linux) CIM Server secure port
• HMC/IVM CIMOM
6641 TCP Inbound SAS switches
6988 TCP Inbound CIM listener
6989 TCP Inbound CIM listener
6090 TCP Outbound TCP Command Mode communication between IBM Systems Director Server and advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II
8421 TCP Inbound • (All operating system platforms) HTTP communication between IBM Systems Director Server and the IBM Systems Director Web interface
• HTTP used by IBM Power systems to communicate with CIM
8422 TCP Inbound • (All operating system platforms) HTTPS communication between IBM Systems Director Server and the IBM Systems Director Web interface
• HTTPS used by IBM Power systems to communicate with CIM
8470 TCP Outbound Non-SSL communication with the IBM i central server job
8471 TCP Outbound Non-SSL communication with the IBM i database server job
8472 TCP Outbound Non-SSL communication with the IBM i data queue server job
8473 TCP Outbound Non-SSL communication with the IBM i file server job
8474 TCP Outbound Non-SSL communication with the IBM i network print server job
8475 TCP Outbound Non-SSL communication with the IBM i remote command and distributed program call server job
8476 TCP Outbound Non-SSL communication with the IBM i signon server job
9000–9100 TCP Communication Platform-Agent managed system running Xen
9470 TCP Outbound SSL communication with the IBM i central server job
9471 TCP Outbound SSL communication with the IBM i database server job
9472 TCP Outbound SSL communication with the IBM i data queue server job
9473 TCP Outbound SSL communication with the IBM i file server job
9474 TCP Outbound SSL communication with the IBM i network print server job
9475 TCP Outbound SSL communication with the IBM i remote command and distributed program call server job
9476 TCP Outbound SSL communication with the IBM i signon server job
9510 TCP Inbound, Outbound Communication with Common Agent and CAS Web services
9511–9513 TCP Inbound Agent manager
9514–9515 TCP Nonstop ports that are used to make sure Common Agent is restarted automatically if it fails.
Note: Ports must be available, but not firewall accessible.
10000 Events from storage devices
13991 UDP Inbound Receives events sent by advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II
14247 UDP Inbound IBM Systems Director interprocess communication (IPC) with IBM Director Agent 5.20
14248 UDP Outbound IBM Systems Director interprocess communication (IPC) with IBM Director Agent 5.20
14251 UDP Inbound IBM Systems Director Server interprocess communication (IPC) support
20000 TCP Inbound • CAS events
• Communication with VMware
Note: If you plan to manage systems running VMware VirtualCenter, or VMware ESX Server, see the VMware documentation to make sure port requirements are met: www.vmware.com/support/pubs/

50000 TCP Both IBM DB2® Universal Database™ databases


Ports for managed systems (Client )
IBM® Systems Director processes require access to a number of ports on managed systems. Managed systems include Common-Agent managed systems, Platform-Agent managed systems, and Agentless-managed systems.
Table 1. Ports on managed systems
Port TCP or UDP Direction Communication description
22 TCP Inbound SSH communication with:
• Advanced management module and management module
• BladeCenter® I/O modules
• Platform Agent installed on systems running Linux®, including systems managed by HMC and IVM
• SSH used by IBM Power systems to communicate with HMC/IVM
• Non-Windows Agentless-managed systems
135 TCP, UDP Inbound (Windows® only) Software installation and remote access communication with Platform Agent
137 TCP, UDP Inbound (Windows only) Communication with Agentless-managed systems using Microsoft® Windows DCOM
138 TCP, UDP Inbound (Windows only) Communication with Agentless-managed systems using Windows DCOM
139 TCP, UDP Inbound (Windows only) Communication with Agentless-managed systems using Windows Server Message Block (SMB)
161 UDP Inbound SNMP agent communication with:
• Advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II
• BladeCenter I/O modules
• Platform Agent
Note: This port is used when the SNMP agent for the operating system is configured.
• Agentless-managed systems
Note: This port is used when the SNMP agent for the operating system is configured.
427 TCP, UDP Outbound and Inbound SLP communication with:
• Advanced management module, management module, Remote Supervisor Adapter, and Remote Supervisor Adapter II
• Common Agent
• Platform Agent
• IBM Director Agent 5.20
• Service Location Protocol (SLP) service agent or SLP directory agent
445 TCP, UDP Inbound (UDP) (Windows only) Open on Agentless and Platform-Agent managed systems for the following features:
• Software installation
• Remote access communication
• (Agentless-managed systems only) Inventory collection
5988 TCP Inbound (Windows and Red Hat Enterprise Linux) CIM Server unsecure port
5989 TCP Inbound • (Windows and Red Hat Enterprise Linux) CIM Server secure port
• HMC/IVM CIMOM
6988 TCP Inbound CIM listener
6989 TCP Outbound CIM listener
9510 TCP Inbound Communication with Common Agent and CAS Web services
14247 UDP Inbound IBM Systems Director interprocess communication (IPC) with IBM Director Agent 5.20
14248 UDP Outbound IBM Systems Director interprocess communication (IPC) with IBM Director Agent 5.20
15988 TCP Inbound • (For SUSE Linux Enterprise Server) CIM Server (alternative secure port) communication with Platform-Agent managed system
• Service processor communication with SUSE Linux Enterprise Server 10.
• CIM Server (alternative unsecure port) communication with Platform-Agent managed system
15989 TCP Inbound (For SUSE Linux Enterprise Server) CIM Server (alternative secure port) communication with Platform-Agent managed system
20000 TCP Outbound • CAS events
• Communication with VMware
Note: If you plan to manage systems running VMware VirtualCenter, or VMware ESX Server, see the VMware documentation to make sure port requirements are met: www.vmware.com/support/pubs/




Network requirements


IBM® Systems Director requires certain ports to be available and certain network protocols to be installed in order to enable communication among IBM Systems Director components and between the management server and managed systems. In addition, network connectivity must exist between the management server and managed systems, and between the management server and the IBM Systems Director Web interface browser system.
Nameserver (DNS) requirements


Ensure that the nameserver is configured correctly. If the nameserver is not configured correctly, you will encounter problems and potential failure during IBM Systems Director installation.
The following conditions indicate that the nameserver is configured correctly:
• The nameserver address or addresses are correct for your network environment.
• You are able to connect to valid hosts on the network and validate that the connection occurs within a reasonable amount of time.
• All available ports
IBM Systems Director processes require access to a number of ports in the installation and systems-management environment. If these ports are blocked by a firewall or used by another process, some IBM Systems Director functions might not work.





Security requirements
IBM® Systems Director Server supports several products to house the registry used for system security.
User registry products and types
One of the following locations must contain the registry that IBM Systems Director uses for user authentication:
Operating system
The local operating system user registry is the default registry used by IBM Systems Director security.
LDAP
IBM Systems Director includes Lightweight Directory Access Protocol (LDAP) authentication support. LDAP support is disabled by default. The following LDAP servers are supported:
• IBM® Tivoli® Directory Server
• Microsoft® Active Directory
Active directory
The active directory, which is the same as the Microsoft Active Directory, acts as an LDAP server or domain controller. It supports the following types of users and groups:
• Global
• Domain
• Local
• Trusted
Ensure that the IBM Systems Director server is a member of the active directory domain.








IBM Systems Director task support by operating system and agent levels


Some IBM® Systems Director tasks are supported on certain operating systems or only on Platform-Agent managed systems or Common-Agent managed systems. For tasks whose support is not affected in this way, see "IBM Systems Director task support not affected by operating systems."
Support for IBM Systems Director tasks can vary depending on the following items:
• The system or hardware device model (the resource)
• The operating system that is installed on a resource
• The service processor installed in the managed system
• The level of the device drivers that are installed on the managed system
Attention: The device drivers that are available for a managed system depend on the service processor and operating system that are installed on the managed system.
• The level of IBM Systems Director support installed on the system or device. In Table 1, the following symbols are used:
• IBM Systems Director Server indicates the task is supported by IBM Systems Director Server.
• Level 0 indicates the task support is provided by the operating system.
• Level 1 indicates the task is supported for managed resources with Platform Agent installed.
• Level 2 indicates the task is supported for managed resources with Common Agent installed.
Note: Typically, if a task is supported by Common Agent, it is also supported by IBM Director Agent version 5.20. However, support can vary for tasks that update systems or provide cross-platform support:
• IBM i support is provided by IBM Director Agent 5.20 only.
• The Agent Installation Wizard can be used to install subagents only on Common-Agent managed system.
• (Configuration manager) Only operating system configuration plug-ins are supported by Common Agent and IBM Director Agent version 5.20.
• (Update manager) Updates on System x and IBM BladeCenter® systems and the IBM i operating system are supported by Common Agent and IBM Director Agent version 5.20. All other types of updates are supported by Common Agent only.
• (Update manager) Updates on AIX®, Linux® on Power Systems™, and Linux for System z are available only with Common Agent. The ability to distribute Linux updates is only available for Common Agent on Linux.
• (Virtualization manager) IBM Director Agent version 5.20 requires a separate download and installation of the Virtualization Manager extension.
Table 1. IBM Systems Director task support across operating systems
Task Operating systems
AIX IBM i Linux Microsoft® Virtual Server VMware Windows®
Event Log IBM Systems Director Server, Level 2 Levels 1, 2 IBM Systems Director Server, Levels 1, 2 Levels 1, 2 Levels 01, 1, 2
IBM Systems Director Server, Levels 1, 2
File Transfer IBM Systems Director Server, Level 2 Level 2 IBM Systems Director Server, Level 2 Level 2 Level 22
IBM Systems Director Server, Level 2
Inventory (hardware)3
IBM Systems Director Server, Level 2 Levels 1, 2 IBM Systems Director Server, Levels 0, 1, 24
Levels 0, 1, 2 Levels 01, 1, 2
IBM Systems Director Server, Levels 0, 1, 24

Inventory (software) IBM Systems Director Server, Levels 0, 2 Levels 0, 1, 25
IBM Systems Director Server, Levels 0, 1, 2 Levels 0, 1, 2 Levels 0, 1, 2 IBM Systems Director Server, Levels 0, 1, 2
Problems (formerly Hardware Status)6
Level 2 Level 2 7
Levels 1, 2 8, 7
Levels 1, 2 9
Levels 1, 2 10
Levels 1, 2
Process Management IBM Systems Director Server, Level 2 Level 2 IBM Systems Director Server, Level 2 Level 2 11
Level 2 11
IBM Systems Director Server, Level 2
Remote Control IBM Systems Director Server, Levels 0, 2 IBM Systems Director Server, Levels 0, 1, 2 Level 2 Levels 0, 1, 212
IBM Systems Director Server, Levels 0, 1, 2
Remote Command Line IBM Systems Director Server, Levels 0, 2 Levels 0, 1, 2 IBM Systems Director Server, Levels 013, 113, 2 Level 2 Levels 0, 1, 2 IBM Systems Director Server, Level 2
Resource Monitors IBM Systems Director Server, Level 2 Levels 1, 2 IBM Systems Director Server, Levels 1, 2 Console only 14
Console only 14
IBM Systems Director Server, Levels 1, 2
Storage Configuration Manager IBM Systems Director Server IBM Systems Director Server, Levels 1, 28, 15
Levels 1, 2 Levels 1, 2 IBM Systems Director Server, Levels 1, 2 16

Update Manager IBM Systems Director Server, Levels 217
Levels 1, 218
IBM Systems Director Server, Levels 0, 1, 217
Levels 1, 2 19
Levels 1, 219
IBM Systems Director Server, Levels 0, 1, 2 17






tes:
1. Agentless-managed system support is available for VMware ESX Server 3i only.
2. File systems that are displayed for the guest operating system are limited to file systems within its virtual disk.
3. Inventory data provided can vary among Agentless, Platform-Agent, and Common-Agent managed systems.
4. Hardware-platform-specific data is not available for hardware inventory.
5. Software Catalog Signatures not supported
6. Unless otherwise indicated, this task is supported (although the support might be limited) by:
• Out-of-band notifications generated by the service processor
• CIM indications generated by Platform Agent or Common Agent
7. IBM BladeCenter JS21 and JS22 only: Out-of-band notifications generated by a service processor only.
8. Not supported on System z systems.
9. Limited support only.
10. VMware support for the Problems task has the following limitations:
• No support for Platform Agent or Common Agent on VMware ESX Server 3i (Embedded and Installable Editions) although enhanced Agentless support includes Problems support.
• Support is limited for guest operating systems.
• Support for console is limited to out-of-band notifications generated by a service processor or in-band events generated by CIM (CIM support is system specific).
11. Supported on guest operating systems only.
12. Supported on Windows guest operating systems only.
13. Supported for Linux on Power Systems only.
14. Limited support provided by virtualization manager.
15. Not supported for Linux on Power Systems.
16. The IBM BladeCenter SAS RAID Controller Module function is not supported on Windows Server 2008.
17. For detailed information about hardware and operating system support provided by update manager, see "Supported updates."
18. On IBM i 5.4 or later, update manager support is provided for IBM Director Agent 5.20.
19. On guest operating systems, support is provided for Linux updates and IBM Systems Director agent updates only.

Preparing the management server


Before installing IBM® Systems Director Server, make sure that the requirements that are applicable to your system have been met.

Preparing firewalls and proxies for IBM Systems Director


If you have firewalls in your network, or if the management server must use a proxy server to access the internet, you must configure the firewalls and proxy server to enable installation and operation of IBM® Systems Director.
IBM Systems Director must be able to access all the managed objects in the network, and if you will be using a remote management console, the management console and management server must have access to each other. In addition, some functions of IBM Systems Director require access to the internet.
To enable this access, you must configure firewalls and proxies in your network to allow access by IBM Systems Director components.
Complete the following steps to configure firewalls and proxies in your network:
1. Identify the ports that you will use in your systems-management environment and ensure that those ports are open before you start installation. For example, you must ensure that the listener ports for IBM Systems Director Server and Common Agent are open. See "All available ports" for a complete list of the ports that IBM Systems Director components can use.
2. Ensure that internet connections exist to the following internet addresses as they are required by IBM Systems Director and various plug-ins.
Note: IP addresses are subject to change, so the use of DNS names is strongly recommended.
Table 1. Required internet connections
DNS name IP address Port(s) Protocol(s)
Update manager
www.ibm.com 129.42.56.216, 129.42.58.216, 129.42.60.216 443 or 80 https or http
www-03.ibm.com 204.146.30.17 443 or 80 https or http
download2.boulder.ibm.com 207.25.253.8 80 http
download3.boulder.ibm.com 207.25.253.76 80 http
Service and Support Manager
eccgw01.boulder.ibm.com 207.25.252.197 443 https
eccgw02.rochester.ibm.com 129.42.160.51 443 https
www-945.ibm.com 129.42.26.224, 129.42.34.224, 129.42.42.224 443 https
www6.software.ibm.com 207.25.253.41 443 https
www.ecurep.ibm.com 192.109.81.20 443 https
3. If a proxy server is required to access the Internet from the management server, complete the following steps to configure the management server to use the proxy when accessing the Internet.
a. Configure the proxy server to use basic authentication if it is configured for digest or NTLM authentication. The update manager task supports only basic authentication with the proxy server. If digest or NTLM authentication are required, update manager will be unable to access update packages from IBM®.
b. Configure the management server to use the proxy server, if a proxy is required to access the Internet. IBM Systems Director requires Internet access for some functions, including update manager.
Parent topic: Preparing the management server
Previous topic: Preparing the database application
Next topic: Installing firmware and device drivers





Installing firmware and device drivers
Before installing IBM® Systems Director on Red Hat Enterprise Linux®, SUSE Linux, VMware ESX Server, Windows® Server 2003, or Windows Server 2008, you need to install the latest firmware and device drivers for IBM service processors and ServeRAID controllers. To accomplish this, you can either use the IBM UpdateXpress System Pack Installer (UXSPi) or you can install the files manually.
Decide the level of agent management that is required for your system. See "Choosing the management level for managed systems" for information.
RSA II notes for installing on Linux:
• The RSA II daemon requires the libusb and libusb-devel packages, which are typically installed by default. If your distribution or installation does not include or install these packages, you must install them prior to installing the RSA II daemon.
• If you are running Linux, the RSA II daemon requires that you configure RSA II for “Linux OS” prior to installation. Change this setting through the RSA II Web management interface or through a setting found in the system BIOS setup utility.
To install the latest firmware and device drivers for IBM service processors and ServeRAID controllers and ServeRAID Manager plug-ins, it is recommended to use the IBM UpdateXpress System Pack Installer (UXSPi). The UXSPi will automatically install the latest BIOS, IPMI baseboard management controller (BMC), Remote Supervisor Adapter II (RSA II), ServeRAID, and other firmware as required for your server. It will also automatically install the required IPMI device drivers for the BMC and the RSA Server Software for the RSA II. See the IBM Systems support Web site at http://www.ibm.com/systems/support/ and select the appropriate UpdateXpress System Pack Library to download the recommended firmware and drivers for your system.
If you choose to not use the UpdateXpress System Pack Installer, perform the following steps to download and install the latest firmware and device driver files for your Red Hat Enterprise Linux, SUSE Linux, or VMware ESX Server system.
Notes:
• These steps apply to only Red Hat Enterprise Linux, SUSE Linux, or VMware ESX Server systems, though the steps that are required for Windows systems are similar.
• See "Preparing to manage service processors with IBM Director" for more information about service processors.
• If your system contains an Integrated systems management processor (ISMP), you need to instead install LM78 and SMBus drivers. See "Installing the IBM LM78 or SMBus device driver" for information.
1. Install the latest firmware for BMC service processors.
a. Download into a temporary directory the ibm_fw_bmc_XXXXXXX_linux_i386.sh BMC firmware file from http://www.ibm.com/systems/support/. This file is available for all supported Red Hat Enterprise Linux, SUSE Linux, and VMware ESX operating systems, so download the version that applies to your system.
b. Navigate to the temporary directory into which you downloaded the file.
c. Use a console prompt from the temporary directory to run the following command:
./ibm_fw_bmc_XXXXXXX_linux_i386.sh -s -a -s
2. Install the latest daemon for the RSA II service processors.
a. Download into a temporary directory the ibm_svc_rsa2_XXXXXXX_linux_32-64.tgz RSA II daemon file from http://www.ibm.com/systems/support/. This file is available for all supported Red Hat Enterprise Linux, SUSE Linux, and VMware ESX operating systems, so download the version that applies to your system.
b. Navigate to the temporary directory into which you downloaded the file.
c. Use a console prompt from the temporary directory to run the following commands:
d. tar xzf ibm_svc_rsa2_XXXXXXX_linux_32-64.tgz
export PATH=$PATH:/usr/local/bin;./install.sh --update
3. Install the latest firmware for the RSA II service processors.
a. Download into a temporary directory the ibm_fw_rsa2_XXXXXXX_linux_i386.sh RSA II firmware file from http://www.ibm.com/systems/support/. This file is available for all supported Red Hat Enterprise Linux, SUSE Linux, and VMware ESX operating systems, so download the version that applies to your system.
b. Navigate to the temporary directory into which you downloaded the file.
c. Use a console prompt from the temporary directory to run the following commands:
d. tar xzf ibm_fw_rsa2_XXXXXXX_linux_i386.sh
export PATH=$PATH:/usr/local/bin;./install.sh --update -force-if-overridden
4. Install the latest firmware and device drivers for ServeRAID controllers.
a. Download into a temporary directory the following individual files that are required for your servers from http://www.ibm.com/systems/support/.
Note: The firmware packages apply to all Linux and VMware ESX distributions, but you must download the appropriate device driver for your particular distribution.
Table 1. Required ServeRAID controller firmware and device driver files
Item Files RHEL AS 4 U6 32-bit RHEL AS 4 U6 64-bit RHEL AS 5 U1 32-bit RHEL AS 5 U1 64-bit SLES 9 32-bit SLES 9 64-bit SLES 10 32-bit SLES 10 64-bit VMware ESX
ServeRAID MR 10 Device driver (systems with ServeRAID 10 hardware) ibm_dd_sraidmr_XXXXXXXX_rhel4_32-64.tgz X X
ibm_dd_sraidmr_XXXXXXXX_rhel5_32-64.tgz X X
ibm_dd_sraidmr_XXXXXXXX_sles9_32-64.tgz X X
ibm_dd_sraidmr_XXXXXXXX_sles10_32-64.tgz X X
ServeRAID MR 10 Firmware (systems with ServeRAID 10 hardware) ibm_fw_sraidmr_XXXXXXXXXXX_linux_32-64.bin X X X X X X X X X
ServeRAID 8 Device driver (systems with ServeRAID 8 hardware) ibm_dd_aacraid_XXXXXXXXXXX_rhel4_32-64.tgz X X
ibm_dd_aacraid_XXXXXXXXXXX_rhel5_32-64.tgz X X
ibm_dd_aacraid_XXXXXXXXXXX_sles9_32-64.tgz X X
ibm_dd_aacraid_XXXXXXXXXXX_sles10_32-64.tgz X X
ServeRAID 8 Firmware (systems with ServeRAID 8 hardware) ibm_fw_aacraid_8k-8kl-X.X.X-XXXXX_linux_32-64.bin X X X X X X X X X
b. Navigate to the temporary directory into which you downloaded the files.
c. Use a console prompt from the temporary directory to run the installation command for each of the downloaded files. Use the following installation command examples as guides:
Example: ServeRAID8 on RHEL5
tar xzf ibm_dd_aacraid_1.1.5.2434_sles10_32-64.tgz
export PATH=/usr/local/bin:$PATH ; ./install.sh --update
./ibm_XX_aacraid_XXXXXXXXXXX_XXXX_XXX.bin -s
Example: ServeRAID10 on RHEL5
tar xzf ibm_dd_sraidmr_XXXXXXXX_rhel5_32-64.tgz
export PATH=/usr/local/bin:$PATH ; ./install.sh --update
./ibm_fw_sraidmr_XXXXXXXXXXX_linux_32-64.bin -s
Preparing to install IBM Systems Director Server on AIX
Before installing IBM® Systems Director Server on AIX®, make sure that your management server meets the applicable requirements.
Complete the following preparatory steps before installing IBM Systems Director Server on AIX:
1. Ensure that your system meets the hardware and software requirements (including those for databases, security, and networking) for installation, as described in "Hardware and software requirements." To verify the AIX operating system level, run the following command:
oslevel -s
The command should return a value such as 5300-06-04-nnn, where nnn is irrelevant.
2. Optional: Download updates for your system, if necessary. Download AIX operating system updates from the "IBM® Fix Central" Web site.
Note: Select "Power" or "System p®" for the Product family and "AIX" for the Product.
3. Ensure that the following required openssl and openssh versions are installed:
• openssl.base 0.9.8.4 or higher
• if installed, openssh.base.server 4.5.0.5301 or higher
There is a dependency between openssl and openssh versions. If openssl is not installed, it is installed as part of the server installation. However, if this would create an inconsistency with the openssh version on the system, openssl is not installed and the server installation fails.
Note: If you want to run the Agent Installation Wizard from the server, openssh is required. However, the server installation does not enforce openssh installation.
4. Note the following list of required RPM files that are installed as part of the IBM Systems Director Server installation:
• bash-3.2-1
• expect-5.42.1-1
• tcl-8.4.7-1
• tk-8.4.7-1
Note: The tk rpm requires that the X11.base.lib file set is also installed. You can find X11.base.lib, along with its X11 installation requisites, on the AIX base installation media.
5. Ensure that the following file sets that are required for and installed with Common Agent on AIX will not conflict with any other applications that are installed on your system:
• sysmgt.cim.providers 1.2.7.35
• sysmgt.cim.smisproviders 1.2.0.35
• sysmgt.cimserver.pegasus 2.6.1.35
• ICU4C.rte 5.3.0.60 (only AIX 5.3 systems)
• xlC.aix50 9.0.0.0 (only AIX 5.3 systems)
• xlC.rte 9.0.0.0 (only AIX 5.3 systems)
6. Ensure that the installation is set to use ports that are not already in use. By default, Common Agent requires ports 9510, 9514, and 9515 during installation and at runtime. If these ports are already in use when you install the agent, the installation will fail. A situation where these ports will be already in use is if you have a different version of the CAS agent installed, for example as part of the Tivoli® Provisioning Manager agent.
Complete the following steps to check for port use and, if any are in use, modify the Common Agent configuration to use different ports:
a. Check if the ports are in use by running the following command:
netstat -an | grep LISTEN | egrep "951(0|4|5)"
b. On the agent system, modify the configuration to use different ports by running the following command:
c. /var/opt/tivoli/ep/runtime/agent/toolkit/bin/configure.sh -unmanaged -port
not_9510 -jport not_9514 -nport not_9515 -force
where not_951x is any open port other than 951x.
d. Rerun the installation script or install the Common Agent file set manually.
7. Optional: If you want to use the FSP Proxy extension, which is necessary for the Power Management tasks for standalone and IVM-managed hosts, ensure that the following necessary file sets are installed.
Note: IBM Systems Director Server no longer automatically installs these file sets to prevent possible installation inconsistencies with CSM.
csm.hc_utils 1.7.0.0 or 1.7.0.10, and csm.hc_utils 1.7.0.13 or higher along with its CSM install requisites
The CSM file set versions 1.7.0.0 and 1.7.0.10 are included on the AIX operating system media. Download the csm_hc.utils 1.7.0.13 file set, which is included in CSM 1.7.0.16, as part of the CSM package from the IBM Cluster Systems Management Web site at http://www14.software.ibm.com/webapp/set2/sas/f/csm/download/home.html. Install each file set with SMIT or the following command:
installp -acgXYd fileset_location fileset_name
where fileset_location is the location of the downloaded file sets and fileset_name is the name of the file set that you are installing.
Director.Server.ext.FSPProxy.rte
Obtain this file set from the IBM Systems Director DVD or the SysDir6_1_Server_AIX.tar.gz and SysDir6_1_Agent_Server_Installp_AIX.tar.gz files. Install the file set with SMIT or the following command:
installp -acgXYd fileset_location Director.Server.ext.FSPProxy.rte
where fileset_location is the location of the downloaded file set.


Preparing to install IBM Systems Director Server on Linux on Power Systems
Before installing IBM® Systems Director Server on Linux® on Power Systems™, make sure that your platform meets the applicable requirements.
Review the following information and complete the necessary steps to prepare your system for installation:
• Ensure that your system meets the hardware and software requirements (including those for databases, security, and networking) for installation, as described in "Hardware and software requirements."
• SUSE Linux Enterprise Server 9 on IBM Power Systems and SUSE Linux Enterprise Server 10 on IBM Power Systems only: Disable the Service Location Protocol daemon (SLPD) before installing Platform Agent. IBM Systems Director Server does not discover a managed system with Platform Agent installed when the managed system is running SLPD.
• Ensure that the required RPM files (or later versions) are installed. To check for the fileset, type the following command and press Enter:
rpm -qa | grep
where is the value in the "Required RPMs" column but without the ppc.rpm or ppc64.rpm extension.
Table 1. Required RPMs for Linux on Power Systems
Installation scenario Required RPMs
Red Hat Enterprise Linux AS, version 4.0 for IBM Power compat-libstdc++-.ppc.rpm1
diagela-2.2.2-0.ppc64.rpm2
librtas-1.3.3-0.ppc64.rpm2
lsvpd-0.15.1-1.ppc.rpm2, 3
powerpc-utils-papr-1.0.3-1.ppc64.rpm2
servicelog-0.2.9-0.ppc64.rpm2
expect-5.42*.rpm
Red Hat Enterprise Linux AS, version 5.0 on IBM Power systems compat-libstdc++-.ppc.rpm1
diagela-2.2.2-0.ppc64.rpm2
librtas-1.3.3-0.ppc64.rpm2
lsvpd-0.15.1-1.ppc.rpm2, 3
ppc64-utils-.ppc64.rpm1
servicelog-0.2.9-0.ppc64.rpm2
expect-5.42*.rpm
SUSE Linux Enterprise Server 9 on IBM Power Systems and SUSE Linux Enterprise Server 10 on IBM Power Systems compat-libstdc++-.ppc.rpm1
diagela-2.2.2-0.ppc64.rpm2
librtas-1.3.3-0.ppc64.rpm2
lsvpd-0.15.1-1.ppc.rpm2, 3
powerpc-utils-.ppc64.rpm1
servicelog-0.2.9-0.ppc64.rpm2
expect-5.42*.rpm
• 1 Obtain this RPM from the operating system distribution media.
• 2 Obtain this RPM from the IBM® Service and productivity tools for Linux on Power Systems Web site at www14.software.ibm.com/webapp/set2/sas/f/lopdiags/home.html. Select the appropriate tab for your Linux distribution and follow any special instructions for each RPM.
• 3 If the lsvpd RPM installed on the managed system is at level lsvpd-0.15.1-1, some inventory tables might not show inventory data. To resolve this issue, install lsvpd-1.3 or higher.
Note: Obtain the lsvpd RPM level lsvpd-1.3 or higher from the "SourceForge.net" Web site.
• Obtain the SUSE/Novell Expect RPM from the SUSE/Novell updates Web site at https://ftp3.linux.ibm.com/suse_updates.html. Obtain the Red Hat Enterprise Linux Expect RPM from the Red Hat Enterprise Linux Updates Web site at https://ftp3.linux.ibm.com/redhat_updates.html.
• If you plan to run the Agent Installation Wizard from the server, ensure that openssh is installed.
Note: The server installation does not enforce openssh installation.
• Ensure that SELinux is not set to enforce security policies prior to installing IBM Systems Director.
If your server runs Red Hat Enterprise Linux version 4 or 5, SELinux might be enabled and enforcing security policies on your system. IBM Systems Director Common Agent might have trouble if SELINUX is set to enforcing. Therefore, before you install IBM Systems Director Common Agent, you must set the SELinux policy to permissive.
SELinux runs in any of the following states:
Disabled
SELinux is disabled. You can tell that SELinux is in the disabled state by determining if any of the following conditions are true:
• No files exist in the /selinux/ directory.
• The SELINUX variable in /etc/selinux/config is set to disabled.
Permissive (enabled)
SELinux is enabled but not enforcing any security policies. You can tell that SELinux is in the permissive state by determining if any of the following conditions are true:
• The SELINUX variable in /etc/selinux/config is set to permissive.
• When you run the cat /selinux/enforce; echo command, it outputs a 0.
Note: The echo after the cat command is required so you can read what is printed out by /selinux/enforce.
Enforcing (enabled)
SELinux is enabled and enforcing security policies. You can tell that SELinux is in the enforcing state by determining if any of the following conditions are true:
• The SELINUX variable in /etc/selinux/config is set to enforcing.
• When you run the cat /selinux/enforce; echo command, it outputs a 1.
Note: The echo after the cat command is required so you can read what is printed out by /selinux/enforce.
To set SELinux to permissive, run the following command before you install IBM Systems Director Common Agent:
/usr/sbin/setenforce Permissive
• Optional: If you want to use the FSP Proxy extension, which is necessary for the Power Management tasks for standalone and IVM-managed hosts, ensure that the following necessary file sets are installed.
Note: IBM Systems Director Server no longer automatically installs these file sets to prevent possible installation inconsistencies with CSM.
csm.hc_utils-1.7.0.16-nnn.rpm or higher
Download this file set as part of the CSM package from the IBM Cluster Systems Management Web site at http://www14.software.ibm.com/webapp/set2/sas/f/csm/download/home.html. Install the file set with the following command:
rpm -Uvh csm.hc_utils-1.7.0.16-nnn.rpm
where nnn represents the build number.
src-1.3.0.4-08nnn.ppc.rpm
Download this file set as part of the CSM package from the IBM Cluster Systems Management Web site at http://www14.software.ibm.com/webapp/set2/sas/f/csm/download/home.html. Install the file set with the following command:
rpm -Uvh src-1.3.0.4-08nnn.ppc.rpm
where nnn represents the build number.
FSPProxyServerExt-5.20.3-1_platform.rpm
Obtain this file set from the IBM Systems Director DVD or the SysDir6_1_Server_Linux_Power.tar.gz file. Install the file set with the following command:
rpm -Uvh FSPProxyServerExt-5.20.3-1_platform.rpm
where platform represents the platform.



Operating systems supported by IBM Systems Director 6.1.0


IBM® Systems Director 6.1.0 provides support for many operating systems. However, support varies depending on the selected hardware and IBM Systems Director component.
Purpose

This little command copies things.

DITA


Starting in version 6.1, IBM Systems Director provides a Web interface for use with IBM Systems Director Server. IBM Director Console is no longer required. However, some tasks in the Web interface require the IBM Systems Director Launched Tasks program. For information about the IBM Systems Director Launched Tasks program and the tasks that require it, see "Launched tasks and the IBM Systems Director Launched Tasks program." For operating-system support, see "Operating systems supported by the IBM Systems Director Launched Tasks program."
When preparing to install IBM Systems Director, consider the following information:
• Platform Agent, version 6.1.0 and IBM Director Core Services version 5.20.3 are the same agent.
• Unless stated otherwise, IBM Systems Director provides agentless support for all operating systems listed in this topic.
Table 1. Windows versions supported by IBM Systems Director on System x systems; IBM® and third-party x86-based systems
Operating system IBM Systems Director Server Common Agent Platform Agent
Editions of Windows® for 32-bit systems:
Windows Server 2003 Datacenter Edition, Release 2 X X
Windows Server 2003, Enterprise and Standard Editions, Release 2 X X X
Windows Server 2003 Datacenter Edition (supports Service Pack 2) X X
Windows Server 2003, Enterprise and Standard Editions (supports Service Pack 2) X X X
Windows Server 2008 Datacenter Edition (supports Service Pack 1) X X
Windows Server 2008, Enterprise and Standard Editions (supports Service Pack 1) X X X
Windows Vista, Business, Enterprise, and Ultimate Editions X X
Windows XP Professional Edition (supports Service Packs 1 and 2) X X
Editions of Windows for 64-bit systems:
Windows Server 2003 Datacenter x64 Edition, Release 2 (supports Service Pack 2) X X
Windows Server 2003, Enterprise and Standard x64 Editions, Release 2 (supports Service Pack 2) X X X
Windows Server 2003 Datacenter x64 Edition (supports Service Pack 2) X X
Windows Server 2003, Enterprise and Standard x64 Editions (supports Service Pack 2) X X X
Windows Server 2008 Datacenter x64 Edition (supports Service Pack 1) X X
Windows Server 2008, Enterprise and Standard x64 Editions (supports Service Pack 1) X X X
Windows Vista, Business, Enterprise, and Ultimate x64 Editions X X
Windows XP Professional x64 Edition (supports Service Packs 1 and 2) X X
Other editions of Windows operating systems:
Microsoft® Virtual Server (guest operating system) (Release 2 required, supports Service Pack 1)
Note: Supported guest operating systems are those that are supported by both IBM Systems Director and the specified version of Microsoft. See the Microsoft product documentation for a list of supported operating systems. X X
Table 2. Linux versions supported by IBM Systems Director on System x systems; IBM® and third-party x86-based systems
Operating system IBM Systems Director Server Common Agent Platform Agent
Versions of Linux® for 32-bit systems:
Red Hat Enterprise Linux AS, version 4.0 (supports Updates 5, 6, and 7) X X X
Red Hat Enterprise Linux ES and WS, version 4.0 (supports Updates 5, 6, and 7) X X
Red Hat Enterprise Linux AS, version 5.0 (supports Updates 1 and 2) X X X
Red Hat Enterprise Linux ES and WS, version 5.0 (supports Updates 1 and 2) X X
Red Hat Enterprise Linux AS, ES, and WS, version 5.0, with Xen Kernel (supports Updates 1 and 2) X
SUSE Linux Enterprise Server 9 for x86 (supports Service Packs 3 and 4) X X X
SUSE Linux Enterprise Server 10 for x86 (supports Service Packs 1 and 2) X X X
SUSE Linux Enterprise Server 10, with Xen Kernel (supports Service Packs 1 and 2) X
VMware ESX Server, versions 3.0, 3.0.1, 3.0.2, 3.5, 3.5.1, and 3.5.2, Console X X
VMware ESX Server, versions 3.0, 3.0.1, 3.0.2, 3.5, 3.5.1, and 3.5.2, guest operating systems
Notes:
1. Supported guest operating systems are those that are supported by both IBM Systems Director and the specified version of VMware. See the VMware product documentation for a list of supported operating systems.
2. IBM Systems Director Server is supported on VMware ESX Server if IBM Systems Director Server is supported on the selected guest operating system. X X X
Versions of Linux for 64-bit systems:
Red Hat Enterprise Linux AS, version 4.0, for AMD64 and EM64T (supports Updates 5, 6, and 7) X X X
Red Hat Enterprise Linux ES and WS, version 4.0, for AMD64 and EM64T (supports Updates 5, 6, and 7) X X
Red Hat Enterprise Linux AS, version 5.0, for AMD64 and EM64T (supports Updates 1 and 2) X X X
Red Hat Enterprise Linux ES and WS, version 5.0, for AMD64 and EM64T (supports Updates 1 and 2) X X
Red Hat Enterprise Linux AS, ES, and WS, version 5.0, for AMD64 and EM64T, with Xen Kernel (supports Updates 1 and 2) X
SUSE Linux Enterprise Server 9 for AMD64 and EM64T (supports Service Packs 3 and 4) X X X
SUSE Linux Enterprise Server 10 for AMD64 and EM64T (supports Service Packs 1 and 2) X X X
SUSE Linux Enterprise Server 10, for AMD64 and EM64T, with Xen Kernel (supports Service Packs 1 and 2) X
Table 3. AIX versions supported by IBM Systems Director on IBM Power systems
Operating system IBM Systems Director Server Common Agent Platform Agent
IBM AIX® Version 5.3 (supports TL06 Service Pack 4 or later)
Note: Agentless support includes only discovery, limited remote access, a limited subset of the Agent Installation Wizard task, and the ability to launch the AIX Management Console for IBM AIX Version 6.1 agents. X X
IBM AIX Version 6.1 (supports TL01 Service Pack 1, or later)
Note: Agentless support includes only discovery, limited remote access, a limited subset of the Agent Installation Wizard task, and the ability to launch the AIX Management Console for IBM AIX Version 6.1 agents. X X
Table 4. IBM i versions supported by IBM Systems Director on IBM Power systems
Operating system IBM Systems Director Server Common Agent Platform Agent
IBM i 6.1 (formerly i5/OS®, Version 6 Release 1)
Notes:
1. Platform-Agent managed system support is not provided by the Platform Agent but by the 5722UME product.
2. Agentless support includes only Discovery, Remote Session and a limited subset of the Agent Installation Wizard task.
3. The richer set of features and subagent tasks provided by Common Agent is supported with the IBM Director Agent 5.20 for IBM i that is currently available. X
IBM i 5.4 (formerly i5/OS, Version 5 Release 4)
Notes:
1. Platform-Agent managed system support is not provided by the Platform Agent but by the 5722UME product.
2. Agentless support includes only Discovery, Remote Session and a limited subset of the Agent Installation Wizard task.
3. The richer set of features and subagent tasks provided by Common Agent is supported with the IBM Director Agent 5.20 for IBM i that is currently available. X
Unless otherwise stated, the following table includes IBM Power systems and IBM Power Blade Servers, but excludes Cell Blade Servers.
Table 5. Linux versions supported by IBM Systems Director on IBM Power systems
Operating system IBM Systems Director Server Common Agent Platform Agent
Red Hat Enterprise Linux AS, versions 4.6 and 4.7, on IBM Power Systems™ X X X
Red Hat Enterprise Linux AS, versions 5.1 and 5.2, on IBM Power Systems X X X
Red Hat Enterprise Linux AS, version 5.2, on IBM Power systems (on IBM BladeCenter® QS21 and QS22 Blade Servers) X X
SUSE Linux Enterprise Server 9 on IBM Power Systems (supports Service Packs 3 and 4) X X X
SUSE Linux Enterprise Server 10 on IBM Power Systems (supports Service Packs 1 and 2) X X X
Table 6. Linux versions supported by IBM Systems Director on System z systems
Operating system IBM Systems Director Server Common Agent Platform Agent IBM® z/VM® MAP Agent1
Versions for 31-bit systems:
Red Hat Enterprise Linux AS, version 4.0, for IBM System z (supports Update 7 and earlier) X X
SUSE Linux Enterprise Server 9 for IBM System z (supports Service Pack 4 and earlier) X X
Versions for 64-bit2 systems:
Red Hat Enterprise Linux AS, version 4.0, for IBM System z (64-bit Edition) (supports Update 7 and earlier) X X X
Red Hat Enterprise Linux AS, version 5.0, for IBM System z (64-bit Edition) (supports Update 2 and earlier) X X X X3
SUSE Linux Enterprise Server 9 for IBM System z (64-bit Edition) (supports Service Pack 4 and earlier) X X X X4
SUSE Linux Enterprise Server 10 for IBM System z (64-bit Edition) (supports Service Pack 2 and earlier) X X X X5
• 1 The IBM z/VM Manageability Access Point Agent (MAP Agent) is used by IBM Systems Director 6.1.0 to monitor the virtual machines and associated resources known as a z/VM system. The agent must be running in a virtual machine within the IBM® z/VM, version 5.4 system that is to be monitored.
• 2 64-bit support is by way of 31-bit compatibility mode only.
• 3 IBM z/VM Manageability Access Point Agent requires Red Hat Enterprise Linux AS, version 5.0, for IBM System z (64-bit Edition), Update 2.
• 4 IBM z/VM Manageability Access Point Agent requires SUSE Linux Enterprise Server 9 for IBM System z (64-bit Edition), Service Pack 4.
• 5 IBM z/VM Manageability Access Point Agent requires SUSE Linux Enterprise Server 10 for IBM System z (64-bit Edition), Service Pack 2.





Installing IBM Systems Director on the management server


After preparing your system, use the IBM® Systems Director Server installation procedure for the operating system on which you plan install IBM Systems Director Server.
Prerequisites



Installing IBM Systems Director Server on AIX


After preparing your system, you can install IBM® Systems Director Server on AIX® by downloading the AIX installation file or using the IBM Systems Director for AIX, V6.1.0 DVD. You can perform a standard installation, install using installp or NIM, or you can use a response file to customize the features that are installed.
Important:
• Installation of IBM Systems Director installs IBM Systems Director Server, Common Agent (when applicable), and Platform Agent all together. Therefore, it is not necessary to separately install Common Agent or Platform Agent on the management server after installing IBM Systems Director Server. In most cases, any IBM Systems Director tasks requiring Common Agent or Platform Agent will be performed for systems with IBM Systems Director Server installed.
• Before installing IBM Systems Director Server on a system that has IBM Storage Configuration Manager installed, you must first uninstall IBM Storage Configuration Manager. After installing IBM Systems Director Server, you can re-install IBM Storage Configuration Manager.
• IBM Systems Director Server is not supported to run on a system with workload partitions (WPARs) enabled.
Prerequisites


Preparing to install IBM Systems Director Server on AIX
You can install IBM Systems Director Server on AIX from either installation media or from a downloaded installation package.
Important: The IBM Systems Director Server and Common Agent installation packages for AIX are provided in English only.
Table 1. Installation options for IBM Systems Director Server on AIX
Installation method Title or file name
DVD media IBM Systems Director for AIX, V6.1.0 DVD
Note: To obtain an image of the IBM Systems Director for AIX, V6.1.0 DVD, download the SysDir6_1_DVD_AIX.iso file.
Attention: If you use DVD media to install IBM Systems Director Server, ensure that you allot an additional 1.2 GB of available space in the /opt file system to contain the agent packages that are copied from the DVD at the end of the server installation. The packages are copied to /opt/ibm/director/packaging/agent on the server.
Downloaded installation package • SysDir6_1_Server_AIX.tar.gz (for script installation, as described here)
• SysDir6_1_Server_Agent_Installp_AIX.tar.gz (for installp or NIM installation)
Note: For more information about using installp or NIM to install IBM Systems Director Server, see the IBM Systems Director Best Practices Redwiki. Installing with installp or NIM does not allow the use of a response file.
At the end of the installation process, you can configure a database to use with IBM Systems Director and change security settings.
Note: If you plan to use the default Apache Derby database, you can choose either the basic installation path, which configures Apache Derby by default, or the custom installation path.
To install IBM Systems Director Server, log in as the root user and complete the following steps:
1. Start the installation from the installation source:
Downloaded installation files: To start the installation from a Web download, complete the following steps:
a. Download the installation package from the IBM Systems Director Downloads Web Site at www.ibm.com/systems/management/director/downloads/.
Note: When you download the IBM Systems Director Server installation package from the Web, the agent packages are not included. You need to download and install them separately as described in "Installing agents".
b. To unzip and extract the contents of the installation package, type the following command:
gzip -cd | tar -xvf -
where is the file name of the download package.
c. Change to the directory in which the installation script is located. Type the following command and press Enter:
cd /install_files/
where install_files is the path to the extracted installation files.
DVD media: To start the installation from the DVD, complete the following steps:
d. Insert the DVD into the DVD-ROM drive.
e. If the DVD does not automount, type the following command and press Enter:
mount -v cdrfs -o ro /dev /mnt
where dev is the specific device file for the block device and mnt is the mount point of the drive.
f. To change to the directory in which IBM Systems Director Server is located, type the following command and press Enter:
cd /mnt/server
where mnt is the mount point of the drive.
2. Optional: To customize the installation, for example to select a nondefault database, copy the response file (dirserver.rsp) to a local directory and modify the installation settings in your local copy.
a. Type the following command and press Enter:
cp dirserv.rsp /directory/
where directory is a local directory.
b. Open an ASCII text editor and modify the installation settings in the copy of the dirserver.rsp file. This file is fully commented.
You can specify the following items in the server response file:
• Specify the log file options
• Specify the Web console port numbers
• Specify the TPM hostname and IP address
• Enable or disable the nonstop service, which keeps the server continuously running
Note: In the response file, "1" indicates that an item is to be installed and "0" indicates that an item is not to be installed.
c. Save the modified response file with a new name.
Note: For more information about the dirserver.rsp file, see the IBM Systems Director Best Practices Redwiki.
Tip: After installation, keep the response file for future use and reference.
3. To install IBM Systems Director Server, type one of the following commands and press Enter:
• To accept the default settings:
server/dirinstall.server
• To use the response file:
server/dirinstall.server -r /directory/response.rsp
4. where directory is the local directory to which you copied the response file, and response.rsp is the name of the response file.
5. Optional: Configure IBM Systems Director for use with a database application other than that which is supplied by default. For more information, see "Configuring the database application after IBM Systems Director installation".
Important: You can configure IBM Systems Director for use with your database application at any point after the installation of IBM Systems Director Server, but you must not start the management server until it is completed. Starting the management server before configuring IBM Systems Director to use a database application might result in a loss of function.
6. Complete the following steps to start IBM Systems Director Server:
. Type the following command and press Enter:
/opt/ibm/director/bin/configAgtMgr.sh
a. Use the following information to respond to the configAgtMgr.sh script prompts:
Enter the Resource Manager user ID that you would like to set for your Agent Manager
If you want to register with an existing agent manager, enter the same resource manager user ID as that of the agent manager. If you want to create a new agent manager, enter in any user ID that will then be defined as the resource manager user ID for that new agent manager.
Note: The resource manager user ID is an identifier that is used by IBM Systems Director or other resource managers to communicate with the agent manager; it is not a user ID on the operating system or an LDAP server.
Enter the Resource Manager password to set for your Agent Manager
If you want to register with an existing agent manager, enter the same resource manager password as that of the agent manager. If you want to create a new agent manager, enter in any password that will then be defined as the resource manager password for that new agent manager.
Verify the Resource Manager password to set for your Agent Manager
Reenter the password you entered for Enter the Resource Manager password to set for your Agent Manager.
Enter the Agent Registration password to set for your Agent Manager
If you want to register with an existing agent manager, enter the same agent registration password as that of the agent manager. If you want to create a new agent manager, enter in any password that will then be defined as the agent registration password for that new agent manager.
Verify the Agent Registration password to set for your Agent Manager
Reenter the password you entered for Enter the Agent Registration password to set for your Agent Manager.
Would you like to use an existing Agent Manager (yes or no)?
If you answer yes, ensure that the user ID and passwords that you previously entered match the user ID and passwords of the existing agent manager.
If you answer no, you are done and the configuration will start.
Enter the IP address for the existing Agent Manager
If you answered yes to Would you like to use an existing Agent Manager (yes or no)?, you must provide the IP address of the existing agent manager.
Enter the port number for the existing Agent Manager
If you answered yes to Would you like to use an existing Agent Manager (yes or no)?, you must provide the port number of the existing agent manager. The port number must be a valid number between 0 and 65535.
After you have provided all the requested information, the agent manager configuration script runs and displays a series of status messages.
b. Start IBM Systems Director processes on the management servers by running the smstart command:
/opt/ibm/director/bin/smstart
See the "smstart command" topic for instructions.
c. Type the following command and press Enter:
install_root/bin/smstatus -r
When this command returns a value of Active, the server is started.
7. If you used the DVD for installation, complete the following steps to unmount the drive and remove the DVD:
. Type cd / and press Enter.
a. Type the following command and press Enter:
umount /mnt
where mnt is the mount point of the drive.
b. Remove the DVD from the drive.
The following files and directories remain in the /tmp directory after installation completes:
• /tmp/47 directory
• /tmp/temp.con file
• /tmp/.oslevel.datafiles directory
The following CAS agent runtime files are created by cimserver during runtime:
• /tmp/cimserver_start.conf
Note: This file is deleted when cimserver shuts down. This does not affect cimserver.
• /tmp/cimlistener_start.conf
Note: This file is deleted when cimlistener shuts down. This does not affect cimlistener.
• /tmp/elasocket_cimv2
• /tmp/dpi_socket







Number of hits :
alt="Hit Counter by Digits" border="0" />

ADD this Info

Bookmark and Share